if anyone cares or may have the same problem i found out what was going on and how to fit it:

the issue is that is does not always work on a 5G band. it sometimes does and then after a while it drops out.

So connecting the Chromecast to the 2.4G and not the 5G made it work without losing communications with it after a time.

However when the Wi-Fi drops the Chromecast generally reconnected back to the 5G, therefore bringing the same problems as before.

The default settings on the Home Hub are that the 2.4 and 5 have the same SSiD and password and the devices just connect to whichever they need to.

i could disable the 5G but that seems a bit short sighted

What you need to do is create a different SSiD name for each of the bands (I just suffixed the name with 2.4G and 5G). Then connect the Chromecast only to the 2.4G. Your other devices can be given the password to both bands and work as normal (they connect to whichever band they need to).

Additionally they can speak to the Chromecast regardless of whatever band they are connected to. I have not needed to change any other settings

This has been working like this for 4 days now, and I have noticed the Wifi dropping out and all devices re connect with no issues